Uncategorized

Its working!

A few days ago I started to have problems with my nvidia graphics… Every reboot meant reinstalling nvidia drivers (almost every reboot)

Yesterday I just tought: well everything should be better with 2.6.35, why not give it a try? Doing that yesterday evening was a bad idea since the initramfs package was brocken. (I shouldn’t expect much more in the current ubuntu maveric repos)

Today the package was fixed and I can at least start the system. Right now I’m not using any Xorg file and have the screen running at 1920×1080. Unfortunately I fell the absence of 3d acceleration :(.

The MOST IMPORTANT step this time was to ditch grub2 in favor of grub1. This solved almost all problems with one try.

I’ll post more once I’ve found out anything else!

EDIT:

  • BAD: No sound

EDIT 2:

  • apt-get purge pulseaudio and sound is working again 🙂
Uncategorized

Long day…

Hi there – today I switched to the 2.6.32.23 and updated the nvidia driver to 195.36.31, till now everything seems to work + the temperature of the graphics card (in nvidia-settings) dropped from ~80°C to ~60°C!!! EDIT: I do not know wether it was my system but somehow it didn’t work after a reboot… With sudo apt-get install nvidia-current and an reinstallation of the nvidia driver it works again.

Besides that I found a really bad bug in a php package today:
if(sizeof($path)==0 || substr($path,-1)!="/") $path.="/";
that might look good in the first place but the moment you think about it you should realize it sets the path to / (root dir on Linux)…

To further mix stuff here is a Link to an exercise I had to do.

And the last part: if you’re interested in Android and live in Austria / or somewhere else and the railways system supports tickets by sms or a webservice, tell me! http://code.google.com/p/railticket/ << working on that one

Uncategorized

My new Sony Vaio VPCZ11

YEAHHH!

Yesterday in the morning I got my new notebook – it’s a nice Sony Z 11 :). That one includes an i5, nvidia 330M, 6Gb memory, and 192Gb SSD (three with 64Gb).

First thing i did was to remove the includes windows 7. Next step was to install the current kubuntu 10.04 – that part was a bit troublesome but it’s working by now. Here a small howto to get it running (thanks to Frederik Questier):

  1. Download the current Kubuntu alternate installer and burn it to a cd or create  a bootable usb stick with the “usb-creator-kde”
  2. goto the bios and enable “show raid information”
  3. reboot the system and remove the raid
  4. start the setup (setup your partitions as you like)
  5. when you try to boot your system change the grub commandline from “quiet splash” to “nomodeset i8042.nopnp” (as far as i know to deactivate the intel graphics and enable the touchpad)
    edit:
    nomodset is not to deactivate the intel graphics but to prevent black screens.
  6. add the repositories:

    deb http://ppa.launchpad.net/kernel-ppa/pre-proposed/ubuntu  karmic main

    deb-src http://ppa.launchpad.net/kernel-ppa/pre-proposed/ubuntu karmic main

    and install an older kernel with:

    sudo apt-get update
    sudo apt-get install linux-image-2.6.31-20-generic linux-backports-modules-karmic-generic linux-backports-modules-2.6.31-20-generic linux-headers-2.6.31-20-generic linux-backports-modules-alsa-2.6.31-20-generic

  7. Kill the current X Server to install the latest Nvidia Driver. Download it from http://www.nvidia.com/Download/index.aspx?lang=en-us
  8. Update the Grub 2 Settings (/etc/defaults/grub) and change the line to: GRUB_CMDLINE_LINUX_DEFAULT=”nomodeset i8042.nopnp”
  9. You can also change the GRUB_DEFAULT to (for me it was 4) the right entry of your 2.6.31.20 Kernel
  10. Update the grub configuration with update-grub

Thats it for me 🙂

Now i have a running System including: Full HD Resulution + VGA (haven’t tested HDMI yet), Sound, CD/DVD Drive, WLan, LAN and Backlight of the Keyboard 🙂

Uncategorized

Sony…

Wie manche wissen geht mein Notebook nicht mehr wirklich (Bildschirm bleibt schwarz). Ich habe mir deswegen noch kein neues gekauft weil ich auf ein bestimmtes Modell von Sony warte. Jetzt ist aber das Problem aufgetreten das sich der Text auf der Seite von vorbestellen auf “nicht mehr verfügbar” geändert hat.

Vielen Dank, dass Sie sich für SonyStyle entschieden haben. Sie werden in Kürze von einem Mitarbeiter kontaktiert.

Sie sind jetzt verbunden mit {Name}.

***: Guten Tag, Sie schreiben mit ***. Wie kann ich Ihnen helfen?

MS: wann wird VPCZ11Z9E/B.AT2 verfügbar sein?

***: Dieses Notebook werden wir nicht mehr auf Lager bekommen.

***: Haben Sie weitere Fragen?

MS: wird es das VPCZ11Z9E schon wieder geben oder?

MS: würde es gerne konfigurieren wie im Deutschen sony shop

***: Dieses können wir für Österreich nicht anbieten. Wenn Sie aber eine deutsche Rechnungs- und Lieferadresse haben, können Sie das Notebook über Deutschland konfigurieren und bestellen.

MS: geht es nicht anders? ich sehen nicht ein wieso ich als zahlender kunde diese möglichkeit nicht geboten bekomme

MS: ?

***: Eine ander Option kann ich Ihnen nicht anbieten.

MS: gibt es einen Grund das diese Option in Österreich nicht verfügbar sein wird oder ist dies reine Willkür?

***: Warum das so entschieden wurde, ist mir nicht bekannt.

MS: Ich empfinde es als Frechheit das diese Notebook für Österreich angekündigt wird und dann in keiner weise Verfügbar ist.

***: Das Notebook war bei uns verfügbar, ist aber bereits ausverkauft.

MS: Dann gab es dieses wohl nur für wenige Minuten zu kaufen.

MS: Können sie mir definitiv sagen das dieses für Österreich nicht mehr verfügbar sein wird?

***: Ich kann Ihnen nur sagen, das wir als Onlineshop keinen weiteren Lagereingang erwarten.

MS: Können sie mir eine Person nennen bei der ich mich über diesen Zustand beschweren kann?

***: Ich kann Ihnen keine Person nennen. Sie können uns dieses aber gern per Email zusenden, damit wir es intern weiter geben. Über Kontakt haben Sie entsprechende Option.

MS: Dann sage ich einmal danke und wünsche ihnen noch ein schönes Wochenende.

***: Vielen Dank, dieses wünsche ich Ihnen auch.

Danach kann ich nur sagen: Sony – gehts noch????

Wie kann ein Konzern überleben wenn er eindeutig nicht will das Leute Geld für seine Produkte ausgeben???

Uncategorized

ÖBB und Google Maps

Bis vor kurzem war es möglich über Google Maps Fahrplan Informationen abzufragen. Leider hat sich die ÖBB dazu entschlossen diese Informationen nicht mehr weiterzugeben.

http://www.google.com/support/forum/p/maps/thread?tid=2be0c9f9c428ddc2&hl=en

Da mich diese unverständliche Einschränkung stört habe ich auch an die ÖBB geschrieben:

Guten Tag,

leider ist es nicht mehr Möglich Fahrplan Informationen über Google Maps zu erhalten.

Dies war die beste Möglichkeit Verbindungen auf Android Telefonen zu bekommen. Die ÖBB Webseite selbst ist für suchen vom Handy äußerst ungeeignet. Auch wird hier nicht automatisch die aktuelle Position erfasst.

Mir ist nicht ersichtlich wieso mir als Kunden hier die Möglichkeit genommen wird komfortabel nach Verbindungen zu suchen. Echtzeit Informationen sind zu diesem Zeitpunkt nicht relevant da sie lediglich eine Erweiterung der Funktion darstellen.

Wird es in naher Zukunft eine Lösung für Android geben?

Danke.

Ich warte noch auf eine Antwort.
Uncategorized

Encvfs on (K|X|…)Ubuntu

Today I thought – hey, I really hate it that i have to mount my truecrypt partition prior to work with eclipse.

I was using truecrypt because the encypted folder of ubuntu disabled me of using apache (running as www-data) in those folders. Truecrypt worked find for doing just that, but as the weeks pass by I’m getting really annoyed of having to mount it seperate.

Another drawback by using truecrypt or any other full partition encryption is the inability to do incremental backups. By using an encryption that uses the normal file system as a storage backend this shortcomming doesn’t exist :).

Now I’ve switched to encfs (http://www.arg0.net/encfs) and pam_encfs to mount it on login.

Here’s how its done:

  1. Install the needed packages:

    sudo apt-get install encfs libpam-encfs

  2. Enable pam_encfs in pam.d:

    open the file: /etc/pam.d/common-auth
    add “auth sufficient pam_encfs.so” befor the line with pam_unix.so
    append “use_first_pass” to the line pam_unix.so

  3. Setup encrypted directory:

    encfs /path/to/encrypted/data /path/where/you/want/to/mount/it
    this will create the encrypted files. Also set the rights on your data:
    chmod 775 /path/where/you/want/to/mount/it -R

  4. Setup the pam_encfs config:

    open the file: /etc/security/pam_encfs.conf
    change the line with fuse_default to “fuse_default nonempty
    comment the line with drop_permissions
    and at the end of the file add the line:
    YOURUSERNAME /path/to/encrypted/data /path/where/you/want/to/mount/it -v,–public allow_other,gid=33
    where 33 is the group of www-data (you have to give numeric id’s here)

and now, well that’s it. Your new encrypted folder shoud be up and running on every login!

For this method to work, the user and the Volume must have the same Password!!!

Be aware that by logging in any user on the system can access your folder!
If you do not want that just remove the “–public” and uncomment the “drop_permissions”

EDIT: to append use_first_pass use a space as separator!

Hope you like it.